Discussion:
Problmes
(too old to reply)
David Figueroa
2018-12-03 10:34:28 UTC
Permalink
The following error message appears when I try to run the following code in
cmd. (I use Djanjo version 1.11 and paython 3.7)
*C:\Users\david\PAYTHON\SAIT1>py manage.py runserver*
*Unhandled exception in thread started by <function
check_errors.<locals>.wrapper at 0x03A46468>*


































*Traceback (most recent call last): File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\utils\autoreload.py",
line 227, in wrapper fn(*args, **kwargs) File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\core\management\commands\runserver.py",
line 117, in inner_run autoreload.raise_last_exception() File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\utils\autoreload.py",
line 250, in raise_last_exception six.reraise(*_exception) File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\utils\six.py",
line 685, in reraise raise value.with_traceback(tb) File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\utils\autoreload.py",
line 227, in wrapper fn(*args, **kwargs) File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\__init__.py",
line 27, in setup apps.populate(settings.INSTALLED_APPS) File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\apps\registry.py",
line 85, in populate app_config = AppConfig.create(entry) File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\apps\config.py",
line 94, in create module = import_module(entry) File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\importlib\__init__.py",
line 127, in import_module return _bootstrap._gcd_import(name[level:],
package, level) File "<frozen importlib._bootstrap>", line 1006, in
_gcd_import File "<frozen importlib._bootstrap>", line 983, in
_find_and_load File "<frozen importlib._bootstrap>", line 967, in
_find_and_load_unlocked File "<frozen importlib._bootstrap>", line 677, in
_load_unlocked File "<frozen importlib._bootstrap_external>", line 728, in
exec_module File "<frozen importlib._bootstrap>", line 219, in
_call_with_frames_removed File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\contrib\admin\__init__.py",
line 4, in <module> from django.contrib.admin.filters import ( File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\contrib\admin\filters.py",
line 10, in <module> from django.contrib.admin.options import
IncorrectLookupParameters File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\contrib\admin\options.py",
line 12, in <module> from django.contrib.admin import helpers, widgets
File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\contrib\admin\widgets.py",
line 151 '%s=%s' % (k, v) for k, v in params.items(), ^SyntaxError:
Generator expression must be parenthesized*
--
You received this message because you are subscribed to the Google Groups "Django users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to django-users+***@googlegroups.com.
To post to this group, send email to django-***@googlegroups.com.
Visit this group at https://groups.google.com/group/django-users.
To view this discussion on the web visit https://groups.google.com/d/msgid/django-users/d253f957-11e6-4020-a967-4edd9ffe8cc5%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Simon Charette
2018-12-03 13:04:38 UTC
Permalink
Hello David,

The current latest version of the Django 1.11 serie doesn't support Python
3.7[0] but
1.11.17, which is still unreleased[1], should per popular demand[2].

Until 1.11.17 is released I'd advise you either stick to Python 3.6 or
upgrade to Django 2.0+.

Cheers,
Simon

[0] https://pypi.org/project/Django/1.11.16/
[1] https://docs.djangoproject.com/en/2.1/releases/1.11.17/
[2] https://groups.google.com/forum/#!topic/django-developers/H7fP5w0YU2I
Post by David Figueroa
The following error message appears when I try to run the following code
in cmd. (I use Djanjo version 1.11 and paython 3.7)
*C:\Users\david\PAYTHON\SAIT1>py manage.py runserver*
*Unhandled exception in thread started by <function
check_errors.<locals>.wrapper at 0x03A46468>*
*Traceback (most recent call last): File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\utils\autoreload.py",
line 227, in wrapper fn(*args, **kwargs) File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\core\management\commands\runserver.py",
line 117, in inner_run autoreload.raise_last_exception() File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\utils\autoreload.py",
line 250, in raise_last_exception six.reraise(*_exception) File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\utils\six.py",
line 685, in reraise raise value.with_traceback(tb) File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\utils\autoreload.py",
line 227, in wrapper fn(*args, **kwargs) File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\__init__.py",
line 27, in setup apps.populate(settings.INSTALLED_APPS) File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\apps\registry.py",
line 85, in populate app_config = AppConfig.create(entry) File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\apps\config.py",
line 94, in create module = import_module(entry) File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\importlib\__init__.py",
line 127, in import_module return _bootstrap._gcd_import(name[level:],
package, level) File "<frozen importlib._bootstrap>", line 1006, in
_gcd_import File "<frozen importlib._bootstrap>", line 983, in
_find_and_load File "<frozen importlib._bootstrap>", line 967, in
_find_and_load_unlocked File "<frozen importlib._bootstrap>", line 677, in
_load_unlocked File "<frozen importlib._bootstrap_external>", line 728, in
exec_module File "<frozen importlib._bootstrap>", line 219, in
_call_with_frames_removed File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\contrib\admin\__init__.py",
line 4, in <module> from django.contrib.admin.filters import ( File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\contrib\admin\filters.py",
line 10, in <module> from django.contrib.admin.options import
IncorrectLookupParameters File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\contrib\admin\options.py",
line 12, in <module> from django.contrib.admin import helpers, widgets
File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\contrib\admin\widgets.py",
Generator expression must be parenthesized*
--
You received this message because you are subscribed to the Google Groups "Django users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to django-users+***@googlegroups.com.
To post to this group, send email to django-***@googlegroups.com.
Visit this group at https://groups.google.com/group/django-users.
To view this discussion on the web visit https://groups.google.com/d/msgid/django-users/7ebfb368-ba6d-45ed-a9b7-1c68f7cdad8c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
David Figueroa
2018-12-03 20:39:13 UTC
Permalink
thank

Em segunda-feira, 3 de dezembro de 2018 10:04:38 UTC-3, Simon Charette
Post by Simon Charette
Hello David,
The current latest version of the Django 1.11 serie doesn't support Python
3.7[0] but
1.11.17, which is still unreleased[1], should per popular demand[2].
Until 1.11.17 is released I'd advise you either stick to Python 3.6 or
upgrade to Django 2.0+.
Cheers,
Simon
[0] https://pypi.org/project/Django/1.11.16/
[1] https://docs.djangoproject.com/en/2.1/releases/1.11.17/
[2] https://groups.google.com/forum/#!topic/django-developers/H7fP5w0YU2I
Post by David Figueroa
The following error message appears when I try to run the following code
in cmd. (I use Djanjo version 1.11 and paython 3.7)
*C:\Users\david\PAYTHON\SAIT1>py manage.py runserver*
*Unhandled exception in thread started by <function
check_errors.<locals>.wrapper at 0x03A46468>*
*Traceback (most recent call last): File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\utils\autoreload.py",
line 227, in wrapper fn(*args, **kwargs) File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\core\management\commands\runserver.py",
line 117, in inner_run autoreload.raise_last_exception() File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\utils\autoreload.py",
line 250, in raise_last_exception six.reraise(*_exception) File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\utils\six.py",
line 685, in reraise raise value.with_traceback(tb) File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\utils\autoreload.py",
line 227, in wrapper fn(*args, **kwargs) File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\__init__.py",
line 27, in setup apps.populate(settings.INSTALLED_APPS) File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\apps\registry.py",
line 85, in populate app_config = AppConfig.create(entry) File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\apps\config.py",
line 94, in create module = import_module(entry) File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\importlib\__init__.py",
line 127, in import_module return _bootstrap._gcd_import(name[level:],
package, level) File "<frozen importlib._bootstrap>", line 1006, in
_gcd_import File "<frozen importlib._bootstrap>", line 983, in
_find_and_load File "<frozen importlib._bootstrap>", line 967, in
_find_and_load_unlocked File "<frozen importlib._bootstrap>", line 677, in
_load_unlocked File "<frozen importlib._bootstrap_external>", line 728, in
exec_module File "<frozen importlib._bootstrap>", line 219, in
_call_with_frames_removed File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\contrib\admin\__init__.py",
line 4, in <module> from django.contrib.admin.filters import ( File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\contrib\admin\filters.py",
line 10, in <module> from django.contrib.admin.options import
IncorrectLookupParameters File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\contrib\admin\options.py",
line 12, in <module> from django.contrib.admin import helpers, widgets
File
"C:\Users\david\AppData\Local\Programs\Python\Python37-32\lib\site-packages\django\contrib\admin\widgets.py",
Generator expression must be parenthesized*
--
You received this message because you are subscribed to the Google Groups "Django users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to django-users+***@googlegroups.com.
To post to this group, send email to django-***@googlegroups.com.
Visit this group at https://groups.google.com/group/django-users.
To view this discussion on the web visit https://groups.google.com/d/msgid/django-users/72edf73f-f674-4b9e-9ef9-cd47b201f15b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Continue reading on narkive:
Loading...